Back to overview
Degraded
Termination of Rec.Co Website
Jun 15, 2026 at 1:03am UTC
Affected services
rec.co.orange360.net
Updated
Jun 15, 2026 at 1:11am UTC
We are waiting on request to terminate rec.co.orange360.net. In the meantime, a 'coming soon' screen has been overlaid.
Affected services
Created
Jun 15, 2026 at 1:03am UTC
We have started suspending the majority of services from the Rec.Co website, as termination of the website will start momentarily when traffic reduces.
Affected services